Iosdk start ... error ! docker version not supported

all’avvio di “iosdk start” ricevo i messaggi sotto riportati. Devo aver aggiornato la versione di Docker-Desktop su MAC e sembra che la 18.6.3 non sia supportata da iosdk.

Come posso rimediare ?

txs
ciao
G

[ OK ] ‘docker’ cli found. (Docker version 18.06.3-ce, build d7080c1)
[ OK ] ‘docker’ version 18.6.3 is newer than minimum supported 18.3.0
[FAILURE] ‘docker’ not found to be running. Failed to run ‘docker info’
[ OK ] ‘wsk’ cli found. (2019-09-23T17:46:38.323+0000)
[ WARN ] Configure wsk via below command to connect to this server as [guest]

[2020-10-05T10:49:01.786Z] [INFO] Starting OpenWhisk standalone on port 3233
[2020-10-05T10:49:02.267Z] [INFO] Slf4jLogger started
[2020-10-05T10:49:02.519Z] [INFO] Using [/root/.openwhisk/standalone/server-3233] as data directory
[2020-10-05T10:49:02.982Z] [ERROR] [#tid_sid_unknown] [StandaloneDockerClient] Failed to determine docker client version: class org.apache.openwhisk.core.containerpool.docker.ProcessUnsuccessfulException - info: command was unsuccessful, code: 1 (unsuccessful), stdout: 18.06.3-ce, stderr: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

1 Mi Piace

Abbastanza normale… devi installare docker-ce visto che le versioni di docker che si trovano sui vari debian e centos sono vecchissime…

Istruzioni per Docker su Centos

il problema e’ sul mio MAC con Docker_Desktop

questo di seguito il mio “docker version” su MAC. Non capisco iosdk dove trovi la 18.3.6 quando la mia versione di docker risulta 19.03.13.

(myenv) GadaxMagicGadax:io-sdk giovannigadaleta$ docker version
Client: Docker Engine - Community
Cloud integration 0.1.18
Version: 19.03.13
API version: 1.40
Go version: go1.13.15
Git commit: 4484c46d9d
Built: Wed Sep 16 16:58:31 2020
OS/Arch: darwin/amd64
Experimental: false

Server: Docker Engine - Community
Engine:
Version: 19.03.13
API version: 1.40 (minimum version 1.12)
Go version: go1.13.15
Git commit: 4484c46d9d
Built: Wed Sep 16 17:07:04 2020
OS/Arch: linux/amd64
Experimental: false
containerd:
Version: v1.3.7
GitCommit: 8fba4e9a7d01810a393d5d25a3621dc101981175
runc:
Version: 1.0.0-rc10
GitCommit: dc9208a3303feef5b3839f4323d9beb36df0a9dd
docker-init:
Version: 0.18.0
GitCommit: fec3683

Stranissimo io sviluppo normalmente con Docker Desktop…

Mie versioni:

$  iosdk --version
0.5.2
$ docker version 
Client: Docker Engine - Community
 Version:           19.03.12
 API version:       1.40
 Go version:        go1.13.10
 Git commit:        48a66213fe
 Built:             Mon Jun 22 15:41:33 2020
 OS/Arch:           darwin/amd64
 Experimental:      false

A me va. Prova iosdk start -v e vediamo dove si incarta.